Cisco Nexus: Configuration VXLAN.
Configuration VXLAN on Cisco Nexus !!!
First: Legacy Method:
Connect between two servers by Trunk VLAN:
Second: VXLAN Method:
Connect between two servers by VXLAN Tunnel.
First Method:
NXOS-L:
vlan 2
interface Ethernet1/2
switchport access vlan 2
spanning-tree port type edge
no shutdown
interface Ethernet1/1
switchport mode trunk
spanning-tree port type network
no shutdown
NXOS-R:
vlan 2
interface Ethernet1/2
switchport access vlan 2
spanning-tree port type edge
no shutdown
interface Ethernet1/1
switchport mode trunk
spanning-tree port type network
no shutdown
Result:
-------------------------------------------------------------------------------------------------
Second Method: VXLAN !!
NXOS-L:
feature ospf
interface Ethernet1/1
no switchport
ip address 10.3.4.3/24
ip router ospf 1 area 0.0.0.0
ip ospf network point-to-point
no shutdown
interface loopback1
ip address 3.3.3.3/32
ip router ospf 1 area 0.0.0.0
router ospf 1
router-id 3.3.3.3
NXOS-R:
feature ospf
interface Ethernet1/1
no switchport
ip address 10.3.4.4/24
ip router ospf 1 area 0.0.0.0
ip ospf network point-to-point
no shutdown
interface loopback1
ip address 4.4.4.4/32
ip router ospf 1 area 0.0.0.0
router ospf 1
router-id 4.4.4.4
But ping between two servers not unreachable
Configure VXLAN:
NXOS-L:
feature vn-segment-vlan-based
feature nv overlay
vlan 2
vn-segment 10002
interface nve1
no shutdown
source-interface loopback1
member vni 10002
ingress-replication protocol static
peer-ip 4.4.4.4
NXOS-R:
feature vn-segment-vlan-based
feature nv overlay
vlan 2
vn-segment 10002
interface nve1
no shutdown
source-interface loopback1
member vni 10002
ingress-replication protocol static
peer-ip 3.3.3.3
Result:
------------------------------------------------------------------------------------------------------------
Good Luck
https://www.linkedin.com/in/ahmedms/
Comments
Post a Comment